BashをアップデートしたらcURLが使えなくなってた

再起動したらなおった

PHPのcURLでSSLリクエストが失敗するようになってた

Bash、アップデートしたよね

先日Bashの重大な脆弱性、Shellshock(Bashshock)があったのは皆さんご存知ですよね?慌ててアップデート…したよね?

そんなこんなでアップデートしたわけだけれどもあれから数日たった今日、ふとWordpressのダッシュボードを眺めてみるとウィジェットが一部表示されていない。

google-analytics-dashboard-for-wpってプラグインのグラフが表示されていなかった。

丁度プラグイン更新直後だったのでそれも疑ってみたけど、両バージョンで同じ問題が発生していた。

バンドル証明書も正常。

Lasterror

こんなエラーが出ていた。

公式のサポート見ても「サーバーの設定変更が原因の可能性がある、サポートに聞いてみろ」みたいなのしかなくてしばらく困ってた。

試行錯誤したけどなにも解決に至らなかった。

調べ方を変えてみる

調べているとStack OverflowにこんなQAがあった。

Amazon MarketplaceWebServiceOrders requests suddenly failing, PHP curl giving SSL CA cert error? – Stack Overflow

Bashを更新したのが原因かもしれないからApacheを再起動してみろ、とのこと。

したがってphp-fpmと、念の為nginxも再起動した。

これにより無事プラグインが復活した…

ちなみにWordpressニュースウィジェットも「RSS エラー: WP HTTP Error: Problem with the SSL CA cert (path? access rights?)」が出ていた。

お疲れ…

Advertisements

コメントを残す